Home > bugfix, general, improvements, Releases, Ubuntu package > An ubuntu package for 0.9.3 Release Candidate.

An ubuntu package for 0.9.3 Release Candidate.

May 23, 2010

Hello world!

As a result of my bad luck, my development machines died in this year (and the end of the 2009). That is the reason for the 0.9.3 release delay.

I have managed to make an ubuntu package (.deb) for ubuntu 10.04 amd64.  This package is not perfect, and maybe it misses some dependencies. I want to note that i have no experience in making .deb packages, it is made using an automatic builder.

Said that, i can release the package to the wild.

You can read the changelog to see what’s new.

Download here.

Update:

After installing the .deb, install the mysql server/client as needed ( if multiple POS terminals are going to use a single database, only install mysql server on one computer, and mysql client on all).  And then you can create the database using the file included in the package, installed at /usr/share/kde4/apps/lemon/lemon_mysql.sql . Run the script as described in the wiki. If you updated lemonpos, then you may want to update your database, instead of running lemnon_mysq.sql, run the fix script if you update from version 0.9.2 or 0.9.1.

There are two PDF documents installed at /usr/share/doc/lemonpos/ on two folders, one for english and other for spanish.

If you got an error when installing the package, see the error detail, maybe some dependencies are not satisfied.

The dependencies for the package are:

kdebase-runtime
kdelibs5
libc6
libgcc1
libqt4-dbus
libqt4-network
libqt4-sql
libqt4-svg
libqt4-xml
libqtcore4
libqtgui4
About these ads
  1. Dennis
    June 8, 2010 at 5:02 am | #1

    I am a newbie and not a programmer. I hope you can help me out. I installed ubuntu 10.04 and i tried installing lemonpos 9.1 but i keep on having error with the installation. I saw a comment on lanchpad stating that i am using a different versions of ubuntu. They said i need to install ubuntu with a lower version. What should i do? You help is highly appreciated. Thanks

    • June 9, 2010 at 3:48 pm | #2

      Im not an ubutnu expert, but if you have 10.04, the lemonpos version at ubuntu community repo is the 0.9.2.

      I made a package for ubuntu 10.04 64 bits, for the 0.9.3rc1 version… as you may read in the post you commented.
      In this post is all information that i can give to install it. Other source of information is in the wiki.

      Remember to uninstall other versions, including the lemonpos-data package from the ubuntu community repo.

  2. October 22, 2010 at 9:45 am | #3

    hi, mchavezg, Lemon is lovely. Kudos!

    1. Bug!

    I use Ubuntu 9.04. I installed the ‘most recent’.deb from sourceforge, ran the database generating script- however Squeeze crashed without even leaving debug traces.

    2. Tweak!

    When i installed lemon from Ubuntu(9.04) repositories using synaptic, no database generating script could be located anywhere! :-(

    Here is the little trick i used:

    1. Open mysql and give password when prompted:

    my sql -u root -p

    2. open a new mysql useraccount admin with password linux:

    grant all privileges on *.* to admin@localhost identified by ‘linux’ with grant option;

    3. open a new database with the name lemondb:

    create database lemondb;

    4. quit mysql:

    quit

    5. Then run squeeze.
    Lo it started seemingly all well! :-)
    IS THIS METHOD OK?

Comments are closed.
Follow

Get every new post delivered to your Inbox.

%d bloggers like this: